This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5 inch HDMI screen advice?
#1
https://www.wantitall.co.za/pchardware/s...b06x9slzwc

Armbian 

I can easily use the hdmi on my raspberry pi 3 but i wish to use the HDMI on my tinkerboard.

When i plug in the micro usb (old raspi powersupply) to screen and then a (tested) HDMI cable to the board all i get is a White screen. 
This is weird to me since ive hooked my tinkerboard to 2 old HDMI computer monitors and the screen showed but this tiny one is weird.

Advice?

[update 10/2/17]
i contacted the supplier and they supplied me with a list of things to try inside the config-txt.md file

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

thing is for armbian i don't see that file in the raspberry pi standard location when i SSH into the tinkerboard.

My updated question is:
Is the config file in a new location or should i just create new config file and hope the tinkerboard doesnt break?
Reply
#2
Maybe it is because the resolution is not defined in the rockchip hdmi kernel griver: https://github.com/TinkerBoard/debian_ke...dmi-lcdc.c

[url=https://github.com/TinkerBoard/debian_kernel/blob/linux4.4-rk3288/drivers/video/rockchip/hdmi/rockchip-hdmi-lcdc.c][/url]
On the android kernel I added a timing for an 1024x600 and made a custom kernel. If you are able to compile your custom kernel, you could try to add the timing as e.g. I made for my (you would need to search for the right values for your display):

Code:
    {
        .mode = {
            .name = "1024x600p@60hz",
            .refresh = 60,
            .xres = 1024,
            .yres = 600,
            .pixclock = 74250000,
            .left_margin = 160,
            .right_margin = 24,
            .upper_margin = 29,
            .lower_margin = 3,
            .hsync_len = 136,
            .vsync_len = 6,
            .sync = FB_SYNC_HOR_HIGH_ACT | FB_SYNC_VERT_HIGH_ACT,
            .vmode = 0,
            .flag = 0,
        },
        .vic = HDMI_VIDEO_DMT | 10,  //512 | 10
        .vic_2nd = 0,
        .pixelrepeat = 1,
        .interface = OUT_P888,
    },


And in rockchip-hdmi.h can be set the default mode to:
Code:
#define HDMI_VIDEO_DEFAULT_MODE            522 /*1024x600: 522*/
Reply
#3
(10-01-2017, 12:11 PM)lobo Wrote: Maybe it is because the resolution is not defined in the rockchip hdmi kernel griver: https://github.com/TinkerBoard/debian_ke...dmi-lcdc.c

[url=https://github.com/TinkerBoard/debian_kernel/blob/linux4.4-rk3288/drivers/video/rockchip/hdmi/rockchip-hdmi-lcdc.c][/url]
On the android kernel I added a timing for an 1024x600 and made a custom kernel. If you are able to compile your custom kernel, you could try to add the timing as e.g. I made for my (you would need to search for the right values for your display):

Code:
    {
        .mode = {
            .name = "1024x600p@60hz",
            .refresh = 60,
            .xres = 1024,
            .yres = 600,
            .pixclock = 74250000,
            .left_margin = 160,
            .right_margin = 24,
            .upper_margin = 29,
            .lower_margin = 3,
            .hsync_len = 136,
            .vsync_len = 6,
            .sync = FB_SYNC_HOR_HIGH_ACT | FB_SYNC_VERT_HIGH_ACT,
            .vmode = 0,
            .flag = 0,
        },
        .vic = HDMI_VIDEO_DMT | 10,  //512 | 10
        .vic_2nd = 0,
        .pixelrepeat = 1,
        .interface = OUT_P888,
    },


And in rockchip-hdmi.h can be set the default mode to:
Code:
#define HDMI_VIDEO_DEFAULT_MODE            522 /*1024x600: 522*/

building a custom kernel is a bit beyond my abilities very basic java, however very interesting and something I might try.


I did how ever get an update from the supplier and have posted the new information back in first post
Reply
#4
To those fighting with this problem nowadays, one thing that worked for me was based on this tutorial (steemit.com/technology/@not-a-bird/tinkerboard-and-elecrow-5-inch-display) about adding a config to /etc/X11/xorg.conf.d/ but the catch was to add a resolution that was never mentioned anywhere. While trying to solve the problem I used a monitor for reference to check what was supposed to be shown and one of the times I changed from the monitor to the tinkerboard the small display worked perfectly so I decided to test the configuration used for the monitor (shown at /var/log/Xorg.0.log) on the display and it worked! Even being completely different than any reported at Xorg.0.log when the small display was .

[TL;DR]
  • create a file "/etc/X11/xorg.conf.d/02-hdmi-5inches.conf" with the following content:
Section "Monitor"
    Identifier          "HDMI-1"
    ModeLine "1920x1080" 148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync
    Option "PreferredMode" "1920x1080"
EndSection
  • Reboot or restart the display manager

One might play with the numbers to achieve true 800x480 (this solution currently fits the actual 1920x1080 into the small screen) but as this solves for me I won't proceed any further.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)