This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
uart2
#1
Would do I do to turn on uart2?


I'm using picocom to read a device on uart2 that I know is working, 
but I see no output I have reversed RX and TX a couple of times
I have RX, TX and GND connected

Thnaks
dk23
Reply
#2
(09-12-2017, 01:45 AM)dk23 Wrote: Would do I do to turn on uart2?


I'm using picocom to read a device on uart2 that I know is working, 
but I see no output I have reversed RX and TX a couple of times
I have RX, TX and GND connected

Thnaks
dk23
The default function of PIN32(UART2TX/PWM3) and PIN33(UART2RX/PWM2) is PWM function instead of UART function.

To used as UART function, you can try as follow:
1. Modify /boot/hw_intf.conf file
Code:
sudo vim /boot/hw_intf.conf

2. Comment out the pwm setting
Code:
#intf:pwm2=on
#intf:pwm3=on


3. reboot your board
Reply
#3
Thanks for your help, now works as expected

picocom -b 9600 -r -l /dev/ttyS2
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)