This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Broken MicroUSB Power Interface (Can I hard wire with red/black 4 wire USB charger?)
#1
Exclamation 
Hi All! 

First off let me just say how glad I am that I finally found a place where they actually TALK about this board... I have had it for 2 weeks now and any kind of documentation is still very rare to come by..

Anyways, I have a Raspberry Pi 3 Model B, and it's MicroUSB power input port snapped off day one. But within 5 mins I was able to find a guide that circumvented that super easy..

[Example Tutorial #1 for RPI]

[Example Tutorial #2 for RPI]

All I had to do was find 2 SUPER clearly marked nodes on the board.

Needless to say, same thing happened again on my tinker board (made it a couple weeks this time..)

So now i have the microUSB port interface ripped off as cleanly as possible, and stripped my microusb cable down to red and black. 
But, I cant seem to find the positive or the safe ground diode on the tinker board. I definitely have seen the power LED come flashing on/off a bunch of times periodically while looking for it them by grounding off on the empty HDMI port interface and tapping around.. (probably not smart.. i know.. but i was angry..)

Anyone smarter than the average idiot that could point me in the right direction? (possibly take a quick screenshot?) I'm no electrician, that's for sure. 

Thanks to anyone willing to help a brotha out!
Reply
#2
See comments in this forum, at end

https://forum.armbian.com/index.php?/top...d/&page=10

I did the same works fine.
The 2 Red gpio5v pins are 5v and the black one next to them is 0v
Make sure it's 5v you feed in as this bypass any regulation.

I use ebay item below (see link) to get 5v, dropping 12v to 5v, this also doubles the max possible current , so a 12v 1.5 amp adaptor should provide 5v at 3amps max

https://www.ebay.co.uk/p/xl4015-5a-dc-dc...&rdtsrc=vi
Reply
#3
Ugh, Either my board is toast/defective or.. i am just too [*****] stupid to even do the simplest things.. either way.. consider me discouraged and ready to give up on the tinker board all together...

I have tried literally every single circuit configuration i can think of. every single variable i know has been considered.. i might very well be a complete [****] in comparison to the majority here.. but I swear i should have seen something happen by now.. I have yet to boot this thing for the second time (since my micro usbport fell off due to superglue instead of solder.. (way to be cheap on the WORST part asus..)

I have taken the liberty to draw a super fast diagram of what i currently have.. maybe someone can just tell me what to do from there? 

[Image: GNYcqct.jpg]
  1. I have a 5v 2a micro usb wall charger (i know it works it has booted the board before) that i have now cut and split the ground from the SINGLE white plastic coated cable within.. giving me what you see in figure 1 Tongue a Ground, and a 5v power line. 
Am i good so far? (i assume so as this seemed fairly common.. from the very little examples i have come across..


     2. I connected the cable's ground to GPIO pin 6, like others suggest.. (the first ground pin in the array)

Am i still good? (i assume so.. pretty hard to mess that up i think..)


     3. Now, this is where it gets confusing and tricky for me... i don't know if this is right.. but i tried variations of hooking the 5v power wire to both GPIO pin 2 and pin 4 (VCC5V_SYS). No matter what I do.. nothing seems to fire the [******] thing up.. 


Can somebody PLEASSSE tell me what the heck is wrong with what I am doing? I don't understand why someone cant just take a picture of what they have.. i would probably understand it instantly then..
Reply
#4
It looks correct.
The red pins are connected together anyway.
So you only really need to connect to one, but what you have done should work.
Do you know the voltage of the USB charger, make sure it not above 5.5 volts.
Also where the USB port ripped off, this may have damaged the PCB or shorted some tracks.
Do you get any LEDs lighting on the board?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)