This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No audio
#21
(04-23-2017, 05:15 PM)floch Wrote: I tested your speaker-test and I am still with no sound.
Sad

(04-23-2017, 05:15 PM)floch Wrote: I checked alsamixer and option F6 and found that I do not have setup default sound card. Options are USB Audio and rockchip. 
F6 - choose "USB audio" and check "Headphone" and "Headphone 1" is unmuted (not MM) and ~80.

(04-23-2017, 05:15 PM)floch Wrote: I do not know how to do it, to setup default sound card to USB Audio. I hoped that it do PulseAudio Control, but it did not work.
PulseAudio is soundserver and depends on ALSA drivers. Try to "systemctl stop lightdm" that also stops PulseAudio (/usr/bin/pulseaudio daemon) and try ALSA again (direct hw test "speaker-test -c2 -Dhw:CARD=Audio,DEV=2").

[Image: 800px-Pulseaudio-diagram.svg.png]

(04-23-2017, 05:15 PM)floch Wrote: It seems that TinkerOS is not fully configured.
I can not find: /proc/asound/modules /etc/modprobe.d/alsa-base.conf /etc/asound.conf
It is okay, all running in default settings, no additional configurations/modules needed to use ALSA drivers backend-only (sink/source).

(04-23-2017, 05:15 PM)floch Wrote: command pacmd does not works.
"pacmd" works only in session with "/usr/bin/pulseaudio" daemon (under same user).

- Try to visually check connector contacts (connector inside), check cable, use other headphones. 3.5 jack must be fully inserted (there is hot-plug detection contact/pin ("HP_DET#") inside connector).
- Try to check dmesg for some sort of errors (like # dmesg | egrep -i 'usb audio|usb 3-1').
- Try other TinkerBoard.
I left this community in Aug 2017 due to ASUS bad product quality and ASUS community support that did not match my expectation.  Sad
Reply
#22
(04-23-2017, 07:10 PM)mcerveny Wrote: - Try to visually check connector contacts (connector inside), check cable, use other headphones. 3.5 jack must be fully inserted (there is hot-plug detection contact/pin ("HP_DET#") inside connector).
- Try to check dmesg for some sort of errors (like # dmesg | egrep -i 'usb audio|usb 3-1').
- Try other TinkerBoard.


Thanks a lot !!!  It works and I have sound. You helped me.  

It is stupid. I needed only to use more force to plugin the jack into TinkerBoard to find right place inside and to connect jack to board.

I did not pressed jack enough into Tinkerboard.

Thanks much again. I was thinking to return board to supplier.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)